summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEdwin2023-08-24 19:13:41 +1000
committerEdwin2023-08-24 19:13:41 +1000
commit995c1cc45059d0211de0f22d9aae75fa982227a8 (patch)
tree78207461ee82e263e8b714966fffe5bf6a3445d7 /PKGBUILD
downloadaur-savi-dev.tar.gz
build for svn version of savi
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbd6f5d6adb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: subnex <slimed13 at hotmail dot com>
+
+pkgname=savi-dev
+pkgver=r216
+pkgrel=1
+pkgdesc="SaVi simulates satellite orbits and coverage, in two and three dimensions. SaVi lets you explore satellite constellations."
+arch=('x86_64')
+license=('custom:The National Science and Technology Research Center for Computation and Visualization of Geometric Structures (The Geometry Center) University of Minnesota')
+url="https://savi.sourceforge.io/"
+
+conflicts=('savi')
+depends=('tcl' 'tk')
+
+optdepends=('lynx' 'gifsicle' 'geomview' 'netpbm' 'zlib')
+
+makedepends=('subversion')
+
+source=("svn+https://svn.code.sf.net/p/savi/savi-dev/")
+
+md5sums=(SKIP)
+
+
+pkgver(){
+ cd "$pkgname"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "$pkgname"
+ ./configure --prefix=/usr --libexecdir=/usr/lib/$pkgname
+ make ARCH=linux
+}
+
+
+package() {
+
+ DESTDIR=$pkgdir
+ mkdir -p "$DESTDIR/opt" "$DESTDIR/usr/bin/"
+ cp -r "$pkgname" $DESTDIR/opt
+ cp $DESTDIR/opt/$pkgname/savi $DESTDIR/usr/bin/savi
+ cd $DESTDIR/usr/bin
+ sed -i "s/SAVI=\$(cd.*/SAVI=\/opt\/$pkgname/g" savi
+}
+