summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin Diehl2023-12-26 08:08:06 +0100
committerMartin Diehl2023-12-26 08:08:06 +0100
commit24202735a0da373a75480ae4f55170568e433b8d (patch)
treee08d3b8d6cc85af33389892f498e126efe6c82b7 /PKGBUILD
parentaafa3cd3a719fee7237c10f48109356574e68e72 (diff)
downloadaur-scotch.tar.gz
use make to let user control number of jobs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f25cdf1241f4..aa6c83e5ed6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Samuel Williams <samuel.williams@oriontransfer.co.nz>
pkgname=scotch
pkgver=7.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="Software package and libraries for graph, mesh and hypergraph partitioning, static mapping, and sparse matrix block ordering. This is the all-inclusive version (MPI/serial/esmumps)."
url="https://gitlab.inria.fr/scotch/scotch"
license=("custom:CeCILL-C")
@@ -31,14 +31,14 @@ build() {
-D SCOTCH_PTHREAD:BOOL=ON \
-D SCOTCH_PTHREAD_MPI:BOOL=ON \
-D COMMON_PTHREAD_AFFINITY_LINUX:BOOL=ON
- cmake --build build --parallel 4
+ make -C build
}
check() {
if [ -z "$(ldconfig -p | grep libcuda.so.1)" ]; then
export _libcuda=0
fi
- cmake --build build --parallel --target test
+ make -C build test
}
package() {