summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2021-01-05 11:09:24 +0300
committerAnton Leontiev2021-01-05 11:09:24 +0300
commitb004c610827bbba4e47e83a36ec69a11b9e21312 (patch)
tree353e85f60b85f35b003304ec2bd62ef4c9589148 /PKGBUILD
parentb929353bf7e339b14481bad8e50c3be4efffad08 (diff)
downloadaur-scout-git.tar.gz
scout-git: Update to v1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 15 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c5815648973..01bdcf80bf0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,32 @@
-# Maintainer: Anton Leontiev <bunder /at/ t-25.ru>
-_pkgname=scout
-pkgname=$_pkgname-git
-pkgver=20110426.158
-pkgrel=2
+# Maintainer: Anton Leontiev <scileont /at/ gmail.ru>
+pkgname=scout-git
+pkgver=1.0
+pkgrel=1
pkgdesc='A CLI interface to Tomboy and Gnote'
arch=('any')
url='https://github.com/lelutin/scout'
license=('BSD')
-depends=('python2' 'python2-dbus')
-makedepends=('git' 'python2-distribute' 'haskell-pandoc')
+depends=('python-setuptools' 'python-dbus')
+makedepends=('git' 'pandoc')
optdepends=('tomboy: either this one' 'gnote: or that one must be installed')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("$_pkgname::git+git://github.com/lelutin/scout.git" 'scout-man.patch')
+provides=('scout')
+conflicts=('scout')
+source=('scout::git+git://github.com/lelutin/scout.git' 'scout-man.patch')
md5sums=('SKIP'
'67bb8bbfb7370496644c737638566207')
pkgver() {
- cd "$_pkgname"
- echo "$(git log -1 --format="%cd" --date=short | sed 's|-||g').$(git rev-list --count master)"
+ cd ${pkgname%-git}
+ printf '%s' "$(git describe --tags | sed 's/^v//;s/-/.r/;s/-/./')"
}
prepare() {
- cd "$_pkgname"
+ cd ${pkgname%-git}
patch -i "$srcdir/scout-man.patch"
}
package() {
- cd "$_pkgname"
- python2 ./setup.py install --root "$pkgdir"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd ${pkgname%-git}
+ python setup.py install --root "$pkgdir"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
}