summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor Schulz2017-12-17 19:59:27 -0200
committerVictor Schulz2017-12-17 19:59:27 -0200
commitc17a23b29139794e2d0458349b55c0b00070fc58 (patch)
treed51a23da17a2780769552f94e889b76e5f792d48 /PKGBUILD
parent19b2335ae8c3f7b831d6ca483703b0f1b44bed36 (diff)
downloadaur-scv.tar.gz
Cleaned up the package function, following dccafe's suggestion.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 3 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f7499be0057..82ce49219258 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Victor Schulz <schulz89@gmail.com>
+# Maintainer: Victor Schulz <schulz89 at gmail dot com>
pkgname=scv
pkgver=2.0.1
pkgrel=1
@@ -7,7 +7,7 @@ arch=('x86_64' 'i686')
url="http://www.accellera.org/downloads/standards/systemc"
license=('Apache License Version 2.0, January 2004')
depends=('systemc')
-provides=('scv')
+provides=('scv-systemc')
source=("http://www.accellera.org/images/downloads/standards/systemc/$pkgname-$pkgver.tar.gz")
md5sums=('c8791df7ec64a91d04daa418b77bae2b')
@@ -21,17 +21,7 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver/objdir"
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir/" libdir=/usr/lib scvdocsdir=/usr/share/doc/scv examplesdir=/usr/share/doc/scv/examples install
cd ..
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- # Manually fixing documentation directories, see Makefile:
- # FIXME: handle $docdir and/or $docdatadir
- cd "$pkgdir/usr"
- mkdir -p share/doc/$pkgname
- mv *.scv share/doc/$pkgname/
- mv docs/scv/* share/doc/$pkgname/
- rmdir -p docs/scv
- mv examples/scv share/doc/$pkgname/examples
- rmdir examples
}