summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 17:48:45 +0100
committerBartłomiej Piotrowski2018-01-05 17:48:45 +0100
commit235ab277ca3f184b0aff4856097e91246480644d (patch)
tree2cc525b8c69031146e4c1712e36e91a436b29260 /PKGBUILD
downloadaur-sdd.tar.gz
Import from official repositories
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6b49b371582
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+pkgname=sdd
+pkgver=1.52
+pkgrel=8
+pkgdesc="Faster replacement for a program called dd"
+arch=('x86_64')
+license=('GPL')
+url="http://freshmeat.net/projects/sdd/"
+#source=(ftp://ftp.berlios.de/pub/sdd/sdd-$pkgver.tar.gz
+source=(https://arch.p5n.pp.ru/~sergej/dl/2014/sdd-$pkgver.tar.gz
+ build-fix.patch)
+options=(!emptydirs)
+sha256sums=('142b3ec789248ec573eb1f047709c484cc5ae7ac9b49107384cfe4f1ad625d87'
+ 'f14d16807795ec7150f6ffafd75b331889f17aeb4b254b2d2b3acefbad116b19')
+
+build() {
+ cd "$srcdir"/$pkgname-${pkgver}
+ if [ $CARCH = "x86_64" ]; then
+ cp RULES/i686-linux-cc.rul RULES/x86_64-linux-cc.rul
+ cp RULES/i686-linux-gcc.rul RULES/x86_64-linux-gcc.rul
+ fi
+ patch -p1 <"$srcdir"/build-fix.patch
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-${pkgver}
+ make INS_BASE="$pkgdir"/usr install
+ mkdir -p "$pkgdir"/usr/share/man
+ rm -rf "$pkgdir"/usr/include/ \
+ "$pkgdir"/usr/lib/ \
+ "$pkgdir"/usr/man/man3/ \
+ "$pkgdir"/usr/man/man5/
+ mv "$pkgdir"/usr/man/* "$pkgdir"/usr/share/man/
+ chown -R root.root "$pkgdir"
+}