summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Haas2019-07-14 16:25:15 +0200
committerChristoph Haas2019-07-14 16:25:15 +0200
commit099f4cbf8026605c7f7c08ee39054c5f785de2e5 (patch)
tree59e9e8eebb50c19ebf63a761bba935d0381e28e6 /PKGBUILD
downloadaur-099f4cbf8026605c7f7c08ee39054c5f785de2e5.tar.gz
version 7.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3977c8d50be1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: h44z <christoph [at] from [doT] tirol>
+# Contributor: eolianoe <eolianoe [at] gmail [DoT] com>
+# Contributor: Edvinas Valatka <edacval@gmail.com>
+# Contributor: Aaron Lindsay <aaron@aclindsay.com>
+
+pkgname=seafile-git
+pkgver=7.0.1
+pkgrel=1
+pkgdesc="Seafile sync client daemon, latest version."
+arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/haiwen/seafile"
+license=('GPL2')
+depends=("libsearpc" "libevent"
+ "fuse" "python2" "sqlite")
+makedepends=("vala" "intltool")
+conflicts=("seafile-server" "seafile")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+ "libseafile.in.patch"
+ "seaf-cli@.service")
+sha256sums=('c79a186e3a512454cb65d863bd45ecc8ae2c66a0dd2010533f3fed7862fa92f8'
+ 'a2d7f7cf0c59aba97650af62b3cefd0ceb71a1007c34d9369a88e5769c7f6076'
+ 'c37510109c1de64c774896df39aece240c056b54414d2119fca01860211156ba')
+provides=('seafile-client-cli-git')
+
+prepare () {
+ cd "${srcdir}/seafile-${pkgver}"
+
+ patch -p1 -i "${srcdir}/libseafile.in.patch"
+
+ # Fix all script's python 2 requirement
+ grep -s -l -r '#!/usr/bin/env python' "${srcdir}/seafile-${pkgver}" \
+ | xargs sed -i -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|g'
+}
+
+build() {
+ cd "$srcdir/seafile-${pkgver}"
+
+ ./autogen.sh
+
+ ./configure \
+ --enable-console \
+ --prefix=/usr \
+ PYTHON=/usr/bin/python2
+
+ make
+}
+
+package() {
+ cd "${srcdir}/seafile-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "${srcdir}"/seaf-cli@.service "${pkgdir}"/usr/lib/systemd/system/seaf-cli@.service
+}