summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Nikiforov2019-10-17 11:21:36 +0300
committerKonstantin Nikiforov2019-10-17 11:35:10 +0300
commitc9280af49e631f6150cd9e2f8ff22efa985dfcc7 (patch)
tree655aceb90de8083f053264a703ec9140b17b6485 /PKGBUILD
parent2f0eba55894b910da9f496189673e092e2328078 (diff)
downloadaur-seaweedfs-git.tar.gz
Fix net-trace panic after start.
Issue: https://github.com/chrislusf/seaweedfs/issues/1058 PKGBUILD now using pMakefile instead of go-get call.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 567d4f5f0b1b..9e84416033e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=seaweedfs-git
__gitroot=github.com/chrislusf/seaweedfs
pkgver=r2620.7de121d9
-pkgrel=1
+pkgrel=2
pkgdesc="Seaweed-FS is a simple and highly scalable distributed file system, written on Go."
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h' 'arm')
url="https://github.com/chrislusf/seaweedfs"
@@ -10,17 +10,17 @@ depends=( )
makedepends=('git' 'go' 'mercurial' 'gcc')
provides=('seaweedfs')
conflicts=('seaweedfs')
-_gourl=$__gitroot/weed
source=("$pkgname::git+https://${__gitroot}")
sha256sums=('SKIP')
build() {
- GOPATH="$srcdir" go get -v ${_gourl}
+ cd "$srcdir/$pkgname"
+ make
}
package() {
mkdir -p "$pkgdir/usr/bin"
- install -p -m755 "$srcdir/bin/"* "$pkgdir/usr/bin"
+ install -p -m755 "$srcdir/$pkgname/weed/weed" "$pkgdir/usr/bin"
}
pkgver() {