summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorr6eve2022-01-16 14:56:01 +0900
committerr6eve2022-01-16 14:56:01 +0900
commit42d8184f3876cc916818809406e8616ba29f4559 (patch)
tree57769cadd907839646583a8eb1abfeb2b204511d /PKGBUILD
downloadaur-selscan-bin.tar.gz
Version v2.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50a7724b80ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: r6eve <r6eve at acm dot org>
+
+pkgname=selscan-bin
+pkgver=v2.0.0
+pkgrel=1
+pkgdesc='Haplotype based scans for selection'
+arch=('x86_64')
+url='https://github.com/szpiech/selscan'
+license=('GPL3')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("${pkgname}-${pkgver}.tar.gz"::"${url}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('2af823fe191311263687a73d270b1491dd70fa34cade138ad8a62b195a64bce3')
+
+package() {
+ cd "${srcdir}/${pkgname%-bin}-${pkgver#v}"
+
+ install -Dm0755 -t "${pkgdir}/usr/bin/" "bin/linux/${pkgname%-bin}"
+ install -Dm0755 -t "${pkgdir}/usr/bin/" "bin/linux/norm"
+}