summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArtem Vorotnikov2023-12-22 05:32:48 +0300
committerArtem Vorotnikov2023-12-22 05:32:48 +0300
commitdb2e4e0e9cb8a605127448d7c18b55777bd7dc9c (patch)
tree22a57137cde68c14ea2e520454b63424c8b656da /PKGBUILD
downloadaur-sendme.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f8162ecd6f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+pkgname=sendme
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="A tool to send files and directories, based on iroh"
+arch=('any')
+url="https://github.com/n0-computer/sendme"
+license=('MIT' 'Apache')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
+b2sums=('61baef285996c9f3433c89b74fa4e03574865d85d18b3968ee1bf6435e3b6039b4a9011ff978997e86a3decbc6317d4566c2cb51066c0066f21dbe1a142a9646')
+
+prepare() {
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+}
+
+build() {
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+}