summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2023-08-12 21:17:44 +0200
committerChristopher Arndt2023-08-12 21:17:44 +0200
commit4f63aa4adf5c2dd23022b117f606596fd0d9b994 (patch)
treeb7216f7c3a67294f38cbe6a6f288ded72470fef9 /PKGBUILD
parent28e83199fdb41dbcc3f3728ea892d0b6aa7ca9f8 (diff)
downloadaur-sfxr-qt-git.tar.gz
Adopted package
* Fix dependencies + Fix git submodule checkout * Clean up PKGBUILD syntax
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 28 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be37d430448d..36ee8b8f1c08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,52 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
-_pkgname='sfxr-qt'
-pkgname="${_pkgname}-git"
-pkgver=1.3.0.r4.g052ca2b
+_pkgname=sfxr-qt
+pkgname=$_pkgname-git
+pkgver=1.5.0.r9.g2799823
pkgrel=1
-pkgdesc='Qt port of SFXR, a sound effect generator, to generate retro-gaming like sound effects'
-arch=('x86_64')
+pkgdesc='Qt port of SFXR, a sound effect generator for retro-gaming sound effects (git version)'
+arch=(x86_64)
url='https://github.com/agateau/sfxr-qt'
-license=('MIT')
-depends=('hicolor-icon-theme' 'python-jinja' 'python-pyaml' 'qt5-declarative' 'sdl')
-makedepends=('cmake' 'git')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
+license=(MIT)
+depends=(glibc gcc-libs graphite hicolor-icon-theme qt5-base qt5-declarative sdl12-compat)
+makedepends=(extra-cmake-modules cmake git python-jinja python-pyaml)
+provides=($_pkgname)
+conflicts=($_pkgname)
source=("git+${url}.git"
"git+https://github.com/catchorg/Catch2.git"
"git+${url%/*}/qpropgen.git")
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
- cd "${_pkgname}"
+ cd $_pkgname
# Submodule list: https://github.com/agateau/nanonote/raw/master/.gitmodules
git submodule init
- git config submodule.3rdparty/catch2.url "${srcdir}/Catch2"
- git config submodule.qpropgen.url "${srcdir}/qpropgen"
- git submodule update
+ git config submodule.3rdparty/catch2.url "$srcdir"/Catch2
+ git config submodule.qpropgen.url "$srcdir"/qpropgen
+ git -c protocol.file.allow=always submodule update
}
pkgver() {
- git -C "${_pkgname}" describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C $_pkgname describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- export CFLAGS+=" ${CPPFLAGS}"
- export CXXFLAGS+=" ${CPPFLAGS}"
- cmake -B build -S "${_pkgname}" \
- -DCMAKE_BUILD_TYPE='None' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
+ export CFLAGS+=" $CPPFLAGS"
+ export CXXFLAGS+=" $CPPFLAGS"
+ cmake -B build -S $_pkgname \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-Wno-dev
make -C build
}
package() {
- make DESTDIR="${pkgdir}" PREFIX="/usr" -C build install
- install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${_pkgname}/README.md"
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${_pkgname}/LICENSE"
+ make DESTDIR="$pkgdir" PREFIX=/usr -C build install
+ install -Dm644 -t "$pkgdir"/usr/share/doc/$pkgname $_pkgname/README.md
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname $_pkgname/LICENSE
}
# vim: ts=2 sw=2 et: