summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarl Smedstad2024-04-22 08:44:02 +0200
committerCarl Smedstad2024-04-22 08:44:02 +0200
commite4b0e8f1bd78d6f6d5e485e42f8d2c50e2d98f57 (patch)
treeb31899f675547e03b57743e749fb0e88f8799b2c /PKGBUILD
parent1f4c360079212f57cd31504a1de556d7799fbf97 (diff)
downloadaur-shell-gpt.tar.gz
upgpkg: 1.4.3-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dba01b55a120..7283d2b238cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=shell-gpt
_pkgname=${pkgname/-/_}
pkgver=1.4.3
-pkgrel=1
+pkgrel=2
pkgdesc="A command-line productivity tool powered by OpenAI's ChatGPT"
arch=(any)
url="https://github.com/TheR1D/shell_gpt"
@@ -39,6 +39,11 @@ prepare() {
# files from the package.
echo "[tool.hatch.build]" >> pyproject.toml
echo "ignore-vcs = true" >> pyproject.toml
+
+ # Python 3.12 compatibility - called_once_with has been replaced with
+ # assert_called_once_with.
+ sed -i 's/mock_system.called_once_with/mock_system.assert_called_once_with/' \
+ tests/test_shell.py
}
build() {