summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoranthraxx2015-10-23 00:51:56 +0200
committeranthraxx2015-10-23 00:51:56 +0200
commit53f2faa27da9370cf742a5776f87b3140373906a (patch)
tree1fc795203184b55633fe534ef5d085b006b17765 /PKGBUILD
parent7ea8d91ff66fa5915d54d0e4659418fc51e8b6ee (diff)
downloadaur-shellnoob.tar.gz
upgpkg: shellnoob 2.1-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2de1ef3c856..43f8caac50ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=shellnoob
pkgver=2.1
-pkgrel=1
+pkgrel=2
pkgdesc="A toolkit that eases the writing and debugging of shellcode"
url="https://github.com/reyammer/shellnoob"
arch=('any')
@@ -18,15 +18,10 @@ prepare() {
package() {
cd ${pkgname}-${pkgver}
-
- install -Dm 755 shellnoob.py "${pkgdir}/usr/lib/python3.4/site-packages/shellnoob.py"
- install -d "${pkgdir}/usr/bin"
- ln -s "/usr/lib/python3.4/site-packages/shellnoob.py" "${pkgdir}/usr/bin/snoob"
-
+ install -Dm 755 shellnoob.py "${pkgdir}/usr/bin/snoob"
install -Dm 644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
- install -d "${pkgdir}/usr/share/doc/${pkgname}/samples/x86-linux"
- install -Dm 644 samples/x86-linux/* "${pkgdir}/usr/share/doc/${pkgname}/samples/x86-linux"
+ install -Dm 644 samples/x86-linux/* -t "${pkgdir}/usr/share/doc/${pkgname}/samples/x86-linux"
}
# vim: ts=2 sw=2 et: