summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIgor Dyatlov2023-02-08 19:20:39 +0300
committerIgor Dyatlov2023-02-08 19:20:39 +0300
commit2211b138e813558a17687e0812ec69b8207f8942 (patch)
tree3edd597b4373a38e9f0d6a00e9c02a0108ccbbbf /PKGBUILD
parent1452441e93b75c7224d2a238b580ca93f0ca000e (diff)
downloadaur-shortwave.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 430c365a4c9f..3f2c1563cc25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=shortwave
-pkgver=3.1.0
-pkgrel=2
+pkgver=3.2.0
+pkgrel=1
epoch=1
pkgdesc="Find and listen to internet radio stations"
arch=('x86_64' 'aarch64')
@@ -11,8 +11,9 @@ license=('GPL3')
depends=('libadwaita' 'libshumate' 'gstreamer' 'gst-plugins-base' 'gst-plugins-bad' 'gst-plugins-good' 'gst-libav')
makedepends=('git' 'meson' 'cargo' 'wayland-protocols')
checkdepends=('appstream-glib')
-_commit=de062d5f2a2f395bb2c3f8149793d4203593e912 # tags/3.1.0^0
+_commit=6fb4acd47a4eae422270f9543bce2d5f0037504c # tags/3.2.0^0
source=("$pkgname::git+$url.git#commit=$_commit")
+options=('!lto')
b2sums=('SKIP')
pkgver() {
@@ -21,6 +22,7 @@ pkgver() {
}
build() {
+ export RUSTUP_TOOLCHAIN=stable
arch-meson $pkgname build
meson compile -C build
}