summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephan Springer2019-04-18 14:38:59 +0200
committerStephan Springer2019-04-18 14:38:59 +0200
commit76fc2e9c098a3dc3431917064b5d70e224423004 (patch)
tree26be0cf1cc8145bf1a16b521492aeb0028663816 /PKGBUILD
parent96663fea25160adfb49c2812faa561066f8ad5a0 (diff)
downloadaur-76fc2e9c098a3dc3431917064b5d70e224423004.tar.gz
use native Hunspell dictionaries
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 931edabc6721..bd7a756a887b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,16 @@
pkgname=signal-desktop-bin
pkgver=1.24.1
-pkgrel=1
+pkgrel=2
pkgdesc='Private messaging from your desktop'
arch=('x86_64')
url='https://github.com/signalapp/Signal-Desktop'
license=('GPL3')
+depends=('gconf' 'gtk3' 'libnotify' 'nss' 'xdg-utils' 'libxss')
+optdepends=('hunspell-en_US: US English hunspell dictionaries')
provides=('signal-desktop')
conflicts=('signal')
options=('!strip')
-depends=('gconf' 'gtk3' 'libnotify' 'nss' 'xdg-utils' 'libxss')
source=("https://updates.signal.org/desktop/apt/pool/main/s/signal-desktop/signal-desktop_${pkgver}_amd64.deb")
sha256sums=('392a8ce97b8a41ee9f55d39b07ce7a6c7b591c5cc607d5b22d323ed849e7b9a4')
@@ -30,4 +31,10 @@ package() {
sed -e 's,^\(Name=.*\),\1 (Start in Tray),' -e 's,^\(Exec=.*\)%U,\1--start-in-tray %U,' \
"${pkgdir}"/usr/share/applications/signal-desktop.desktop \
> "${pkgdir}"/usr/share/applications/signal-desktop-tray.desktop
+
+ # use native Hunspell dictionaries
+ # unfortunately only US-English is supported, see https://github.com/signalapp/Signal-Desktop/issues/1659
+ rm -r "${pkgdir}"/opt/Signal/resources/app.asar.unpacked/node_modules/spellchecker/vendor/hunspell_dictionaries
+ ln -s /usr/share/hunspell \
+ "${pkgdir}"/opt/Signal/resources/app.asar.unpacked/node_modules/spellchecker/vendor/hunspell_dictionaries
}