summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-01-26 04:21:07 +0100
committerhaawda2018-01-26 04:21:07 +0100
commit73ae6f35cfd8ed748b811385c078ee3e7e9cd4e2 (patch)
tree8e34d7e01f01026873e9b0aa087b4a81ddace8ab /PKGBUILD
downloadaur-slime-company.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61c5e4fd518b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=slime-company
+pkgver=1.1
+pkgrel=1
+pkgdesc="A company-mode completion backend for Slime"
+url="https://github.com/anwyn/slime-company"
+arch=('any')
+license=('GPL3')
+depends=('slime' 'emacs-company-mode')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/anwyn/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd $pkgname-$pkgver
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -d "${pkgdir}"/usr/share/emacs/site-lisp/
+ install -m644 *.el{c,} "${pkgdir}"/usr/share/emacs/site-lisp
+}