summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2020-08-03 22:45:23 -0400
committerTed Alff2020-08-03 22:45:23 -0400
commit1481378f0ae44c726f68c5375f66c9b4be7685f0 (patch)
treedba1c4a9afa8b31e96c7632c7c0284a8c79ff0db /PKGBUILD
downloadaur-slingshot-python3.tar.gz
Initial commit. Python3 version of slingshot.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6ec29043974
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+# Contributor: jsteel <mail at jsteel dot org>
+# Contributor: Erdbeerkaese
+# Contributor: Arkham <arkham at archlinux dot us>
+
+_pkgname=slingshot
+pkgname=${_pkgname}-python3
+epoch=1
+pkgver=0.9+5+g243aef9
+pkgrel=1
+pkgdesc="A 2D strategy game in the gravity fields of several planets (python3 port)"
+arch=('any')
+url="https://github.com/indritbashkimi/slingshot"
+license=('GPL')
+depends=('python-pygame' 'python-docopt')
+makedepends=('python-distutils-extra' 'git')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}=${pkgver}")
+source=("${_pkgname}::git+https://github.com/indritbashkimi/slingshot.git#branch=python3")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed "s/-/+/g"
+}
+
+package() {
+ cd "${_pkgname}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" \
+ --no-compile -O0
+}