summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlphaJack2021-09-11 13:04:13 +0200
committerAlphaJack2021-09-11 13:04:13 +0200
commit694f576074c377f132297d8fe460944a7ae50327 (patch)
treec6bc5d58d0cd2752d7909d140e0c2b1b77ecb074 /PKGBUILD
parentac1980e4d8e5893757fedf3b61dd35f983bb75c1 (diff)
downloadaur-smarty3-gettext.tar.gz
Updated package to 1.6.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 17 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2fdc4564c4a..f2fe3dfd5d54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,23 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+# Contributor K1412 <swaelens.jonathan@openmailbox.org>
-# Maintainer: K1412 <swaelens.jonathan@openmailbox.org>
-pkgname=smarty3-gettext
-pkgver=1.1.0
+pkgname="smarty3-gettext"
+pkgver=1.6.2
pkgrel=1
-pkgdesc="smarty3-gettext provides gettext support for Smarty,
-the popular PHP templating engine (http://smarty.php.net/)."
-arch=('any')
+pkgdesc="Gettext support for Smarty"
url='https://github.com/smarty-gettext/smarty-gettext'
-depends=('smarty3')
-conflicts=('smarty3-i18n')
licence='LGPL'
-
-source=("https://github.com/smarty-gettext/smarty-gettext/archive/${pkgver}.tar.gz")
-md5sums=('ea0728f159d2c3cf42f62156fd9c4ef7')
-
-prepare() {
- cd smarty-gettext-${pkgver}/
-
- # Right for executables
- chmod 750 ./tsmarty2c.php
-}
-
-
-package() {
- cd smarty-gettext-${pkgver}/
-
- mkdir -p ${pkgdir}/usr/share/php/smarty3/plugins/
- cp ./block.t.php ${pkgdir}/usr/share/php/smarty3/plugins/
-
- mkdir -p ${pkgdir}/usr/bin/
- cp ./tsmarty2c.php ${pkgdir}/usr/bin/
-
- mkdir -p ${pkgdir}/usr/share/doc/${pkgname}/
- cp -a ./tests/ ${pkgdir}/usr/share/doc/${pkgname}/
- cp ./COPYING ${pkgdir}/usr/share/doc/${pkgname}/
- cp ./ChangeLog.md ${pkgdir}/usr/share/doc/${pkgname}/
- cp ./README.md ${pkgdir}/usr/share/doc/${pkgname}/
+arch=('any')
+depends=('smarty3')
+source=("$url/archive/$pkgver.tar.gz")
+sha256sums=('06a4c7b7f6745e1227b4b5181d15836f8e0af46a776903c9edd9cda09300ebd4')
+
+package(){
+ cd "smarty-gettext-$pkgver"
+ install -D -m 644 "block.t.php" "$pkgdir/usr/share/php/smarty3/plugins/block.t.php"
+ install -D -m 644 "function.locale.php" "$pkgdir/usr/share/php/smarty3/plugins/function.locale.php"
+ install -D -m 755 "tsmarty2c.php" "$pkgdir/usr/bin/tsmarty2c.php"
+ gzip -f "tsmarty2c.1"
+ install -D -m 644 "tsmarty2c.1.gz" "$pkgdir/usr/man/man1/tsmarty2c.1.gz"
}