summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRecolic Keghart2020-01-30 08:26:02 -0800
committerRecolic Keghart2020-01-30 08:26:02 -0800
commit81da4bc80b002e9ca398e40408443204609ed370 (patch)
treee48c0e695afa5bd19b9b343472a65fac54bee582 /PKGBUILD
parent94a7edea93c377c7594e2ae6aad31bb7b3b70468 (diff)
downloadaur-snakesocks.tar.gz
update to 1.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b41bb2335f6c..56ffb5d48c47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,27 @@
# I'm really sorry but providing our name is dangerous to us. Github: https://github.com/snakesocks
pkgname=snakesocks
-pkgver=1.3.1.2
+pkgver=1.4.0
pkgrel=0
pkgdesc="An extensible proxy which prevents some ISP from detecting network traffic."
url="https://github.com/SnakeSocks/$pkgname"
license=("GPL2")
arch=("i686" "x86_64")
depends=("glibc>=2.14" "gcc-libs")
-makedepends=("boost>=1.55" "go" "cmake>=3.5" "make")
+makedepends=("boost>=1.55" "cmake>=3.5" "make")
conflicts=("$pkgname-bin")
replaces=("$pkgname-bin")
backup=("etc/$pkgname/conf/client.conf" "etc/$pkgname/conf/server.conf")
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
validpgpkeys=("00D386A853D34998CC1D232A99B730DA4B48AF32")
-sha256sums=("30e5dd69194f83d040e6daae388a4d3b87b2044a0009f1ab3692bfd1916ed994")
+sha256sums=("5448ce9e4762de58cce32aa021cae1abf9f03a2a3022ba594f0af18fe6b652dc")
package() {
export pkgdir
cd "$pkgname-$pkgver"
make default_modules
- make client # requires cmake and boost
- make server # requires go. comment it if you dont want it.
+ make native # requires cmake and boost
+ # SnakeSocks 1.4.0+ provides both native client and native server, with 'make native'
make install
}