summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMike Swanson2022-07-17 07:52:37 -0700
committerMike Swanson2022-07-17 07:52:37 -0700
commit2634cc894bb9aff86131993efd72efadc78d2a79 (patch)
treefde2b3343d1b7a1f734a9ee2f25673ce309f8c4e /PKGBUILD
parent84a7b1da012b26ab9c7970684cee5c8692ae4af9 (diff)
downloadaur-sng.tar.gz
Include Debian’s patches: manpage typo correction and large file support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 19 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90e2970a6a6e..e760112e110a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,36 @@
pkgname=sng
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Convert PNGs to and from a text format representation"
+debpatch=4
arch=('i686' 'x86_64')
url="http://sng.sourceforge.net/"
license=('BSD')
depends=('libpng' 'netpbm')
-source=("http://sourceforge.net/projects/$pkgname/files/$pkgname-$pkgver.tar.gz")
-sha256sums=('119c55870c1d1bdc65f7de9dbc62929ccb0c301c2fb79f77df63f5d477f34619')
+source=("https://sourceforge.net/projects/$pkgname/files/sng-${pkgver}.tar.gz"
+ "https://deb.debian.org/debian/pool/main/s/sng/sng_${pkgver}-${debpatch}.debian.tar.xz")
+b2sums=('66a013f5d0875766f249b3c75aceb8991e3a58dbbd3e02d1c845711547c71ce886334197edceafc90cbe0bf07f70bd46e4cca1a93e6a411b1605991ff098d0be'
+ '5f77805994ed40f0517d6276910b43e7fd77e4e78313b80ae8181bcc334a051acf67ecc74d02bfe4575546ddc59ce6cbeca6da79e2a17e71881132f2b5ad356f')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ while read patch; do
+ patch -p1 -i ../debian/patches/"${patch}"
+ done < ../debian/patches/series
+
+ rm Makefile
+ autoreconf -fi
+}
build() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
./configure --prefix=/usr --with-rgbtxt=/usr/share/netpbm/rgb.txt
make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}