summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Beaumont2021-04-08 23:55:58 +0200
committerMichael Beaumont2021-04-08 23:55:58 +0200
commit5a8d87efdd91bfeec1950813bdc02c9d72cec379 (patch)
treea428b4096bcbe37f7c871cc260d9ae55984e5b39 /PKGBUILD
parentc19323e111da65c842e51f5e5416f287a2ef2630 (diff)
downloadaur-sops.tar.gz
Update to 3.7.1
Release updated on github.com Also include michaelbeaumont/aur-packages#4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b824c4dca58c..64c62c406f61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=sops
pkgver=3.7.1
-pkgrel=1
+pkgrel=2
pkgdesc='Editor of encrypted files that supports YAML, JSON and BINARY formats'
arch=('i686' 'x86_64' 'aarch64')
url='https://github.com/mozilla/sops'
@@ -12,11 +12,12 @@ depends=('glibc')
makedepends=('go')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
sha256sums=(
- '2d16104b94f7f4252decff85a331dc94a9b1e7aed8dcb605c114c60df542d004'
+ '536ee140d888b53b71c1e8edd669f4c11bc573428983fbea644fbbfcd7d7079a'
)
build() {
cd "${pkgname}-${pkgver}"
+ export GOPATH="$srcdir"/gopath
export CGO_LDFLAGS="$LDFLAGS"
export GOFLAGS='-buildmode=pie -modcacherw -trimpath'
go build -o "$pkgname" ./cmd/sops/