summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2018-02-11 19:07:43 +0100
committerFabioLolix2018-02-11 19:07:43 +0100
commit4ac46d06a4b057adf19c4e5ffb4f74c1e84e5d68 (patch)
tree1b53d0519d223f2e346f6ed4557adf247220982d /PKGBUILD
parent2fce8321beb35809ec5fbc996afee1415a637e59 (diff)
downloadaur-soundnode-app-bin.tar.gz
v7.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 25 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b3dc63cb020..be0c8d7fd807 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,33 @@
-# Maintainer: Rick Kerkhof <rick.2889@gmail.com>
+# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+# Contributor: Rick Kerkhof <rick.2889@gmail.com>
+
pkgname=soundnode-app-bin
-pkgver=0.6.5
-pkgrel=2
-pkgdesc="Soundcloud client for the desktop"
-arch=('x86_64' 'i686')
+pkgver=7.0.0
+pkgrel=1
+pkgdesc="Unofficial Soundcloud client for the desktop build with Electron"
+arch=('x86_64')
url="http://www.soundnodeapp.com/"
license=('GPL3')
-conflicts=('soundnode', 'soundnode-git')
+conflicts=('soundnode' 'soundnode-git')
provides=('soundnode')
-
-
-# Required, otherwise it won't run.
options=('!strip')
-
-depends=('gconf' 'gtk2' 'libxtst' 'nss' 'alsa-lib' 'libnotify' 'fontconfig')
-
-# I couldn't figure out how to build it properly and the website has no per-release
-# archives. The SHA256sums will fail if it updates; that should be an indication that
-# this package has become out of date.
-source_x86_64=("http://www.soundnodeapp.com/downloads/linux64/Soundnode.zip")
-source_i686=("http://www.soundnodeapp.com/downloads/linux32/Soundnode.zip")
-
-# Generic sources.
-source=("https://raw.githubusercontent.com/Soundnode/soundnode-app/$pkgver/app/soundnode.png"
-"soundnode-app.desktop")
-
-sha256sums=('a16acc740d94ed119f943e810f44cdb2d082153645aafc1c179f15fb5b9a7619'
- 'd96b0f8c37bf51f50c1129f01262e35b24ab615976a7cb4b11427af11eeee819')
-sha256sums_x86_64=('ecf085044347a4b35ea4c558ab65296edd8c107f84f88fb5e88e5b72454475c1')
-sha256sums_i686=('b5ff7b2008ee327f93e31b7dd9179ebf30fa6b49c9234abe5bff788f38918b97')
-
-# Generic checksums.
+depends=('gconf' 'gtk2' 'libxtst' 'nss' 'alsa-lib' 'libnotify' 'fontconfig' 'libxss')
+source=("https://github.com/Soundnode/soundnode-app/releases/download/${pkgver}/Soundnode-linux-x64.tar.xz"
+ "https://raw.githubusercontent.com/Soundnode/soundnode-app/${pkgver}/app/soundnode.png"
+ 'soundnode.desktop')
+sha256sums=('f45d389ad83db00e1eb9a735e24fa2a25b5819ffc29ee0728baffdba8e4d12bc'
+ 'a16acc740d94ed119f943e810f44cdb2d082153645aafc1c179f15fb5b9a7619'
+ 'b5534a261b91881fe173052c9ede70dc385f105b5d7586af16edab079a115270')
+PKGEXT='.pkg.tar'
package() {
- install -dm755 "$pkgdir"/usr/bin
- install -dm755 "$pkgdir"/opt/
- install -dm755 "$pkgdir"/usr/share/applications/
- install -Dm644 "$srcdir"/soundnode-app.desktop "$pkgdir"/usr/share/applications/
-
- # We're creating a broken link here. It'll be fixed when all files are in place :)
- ln -s /opt/soundnode-app-bin/Soundnode "$pkgdir"/usr/bin/soundnode
-
- rm "$srcdir"/Soundnode.zip
- rm "$srcdir"/soundnode-app.desktop
- cp -Lr "$srcdir" "$pkgdir"/opt/"$pkgname"
+ cd ${srcdir}/Soundnode-linux-x64
+ install -d ${pkgdir}/usr/{bin,share/{applications,pixmaps,licenses/${pkgname}}}
+ install -d ${pkgdir}/opt/soundnode
+ install -D ../soundnode.desktop ${pkgdir}/usr/share/applications/
+ install -D ../soundnode.png ${pkgdir}/usr/share/pixmaps/
+ ln -s /opt/soundnode/Soundnode ${pkgdir}/usr/bin/soundnode
+ cp -r * ${pkgdir}/opt/soundnode
+ cp -r ${pkgdir}/opt/soundnode/resources/app/LICENSE.md ${pkgdir}/usr/share/licenses/${pkgname}/
+ mv ${pkgdir}/opt/soundnode/LICENS{E,ES.chromium.html} ${pkgdir}/usr/share/licenses/${pkgname}/
}