summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorD3SOX2024-01-29 17:14:27 +0100
committerD3SOX2024-01-29 17:14:27 +0100
commit7175471bb7dae0e628de0d58ae97e7b4183bb3f8 (patch)
tree5406fb2e0ea23088b13500f28c0aaa9738f29c01 /PKGBUILD
parent6796f463b50e2a35160f836273c84507e9a1a538 (diff)
downloadaur-soundux-git.tar.gz
move submodule update to prepare
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 13c7dd3ccf03..1b037966f842 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Nico <d3sox at protonmail dot com>
pkgname=soundux-git
-pkgver=r1391.a4fc381
+pkgver=r1432.fca05c9
pkgrel=2
epoch=1
pkgdesc="A cross-platform soundboard - unstable development version"
@@ -23,9 +23,13 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
+prepare() {
cd "${srcdir}/Soundux"
git submodule update --init --recursive
+}
+
+build() {
+ cd "${srcdir}/Soundux"
mkdir -p build
cd build
cmake -GNinja -DCMAKE_BUILD_TYPE=Release ..