summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2018-06-16 12:06:55 +0200
committerFabioLolix2018-06-16 12:06:55 +0200
commitf523b5eb5e181865d77d7ca9b3f8900b5b59c6d1 (patch)
treef95331aa3db99fe93dabf77abe542b014f035b36 /PKGBUILD
downloadaur-sparky-dashboard-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9115eb7eab6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer:
+
+pkgname=sparky-dashboard-git
+pkgver=r4.46912d8
+pkgrel=1
+pkgdesc="The Sparky dashboard displays applications from /usr/share/applications dir into yad based window"
+arch=('any')
+url="https://github.com/sparkylinux/sparky-dashboard"
+license=(GPL3)
+depends=('yad')
+makedepends=('git')
+provides=('sparky-dashboard')
+conflicts=('sparky-dashboard')
+source=("${pkgname}::git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm775 ${srcdir}/${pkgname}/bin/sparky-dashboard ${pkgdir}/usr/bin/sparky-dashboard
+ install -Dm775 ${srcdir}/${pkgname}/share/sparky-dashboard.desktop ${pkgdir}/usr/share/applications/sparky-dashboard.desktop
+}