summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaroslav Lichtblau2016-07-03 13:04:17 +0200
committerJaroslav Lichtblau2016-07-03 13:04:17 +0200
commitcd756dc0d658059bc9b99538bdc4e52bf73b61bf (patch)
tree6d5537aa9f6d08dcb9c05153e18b46503360b076 /PKGBUILD
parent636f8334573c65b1cb943967e44ec82fbbb88602 (diff)
downloadaur-specto-bzr.tar.gz
specto-bzr PKGBUILD fix and update to v176
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 599b00c66f4b..9c93fa3af424 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,22 @@
# Contributor: Kessia 'even' Pinheiro <kessiapinheiro at gmail.com>
pkgname=specto-bzr
-pkgver=126
-pkgrel=2
+pkgver=176
+pkgrel=1
pkgdesc="A desktop application that will watch configurable events"
arch=('any')
url="http://code.launchpad.net/specto"
license=('GPL2')
depends=('python2-notify' 'gnome-python-extras' 'dbus-python' 'pygtk' 'gnome-icon-theme')
-makedepends=('bzr' 'librsvg')
+makedepends=('bzr' 'librsvg' 'intltool')
conflicts=('specto' 'specto-svn')
provides=('specto')
-install=$pkgname.install
-
source=()
-md5sums=()
_bzrbranch=https://code.launchpad.net/~specto/specto/main
_bzrmod=specto
-build() {
+prepare() {
cd "${srcdir}"
msg "Connecting to the server...."
@@ -38,8 +35,14 @@ build() {
cp -r ./$_bzrmod ./$_bzrmod-build
}
+build() {
+ cd "${srcdir}"/$_bzrmod-build
+
+ python2 setup.py build
+}
+
package() {
- cd ./$_bzrmod-build
+ cd "${srcdir}"/$_bzrmod-build
python2 setup.py install --prefix=/usr --root="${pkgdir}"
}