summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoliathLabs2020-05-12 22:26:23 +0200
committerGoliathLabs2020-05-12 22:26:23 +0200
commit887bfab00193ffbf592692179c5cc0d301749126 (patch)
tree4b8cd5e59f452375344dc8e327723c2d25085c3f /PKGBUILD
parentbe9cce7ba363947a370337a53a3f2e75f38de00a (diff)
downloadaur-spnego-http-auth-nginx-module-git.tar.gz
Updated: nginx 1.18.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 84a4f865b5f4..03618181c03d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,37 @@
-# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Gavin Lloyd <gavinhungry@gmail.com>
-_module=spnego-http-auth-nginx-module
-_nginx=$(command -v nginx > /dev/null && nginx -v 2>&1 | awk -F'nginx/' '{print $NF}')
-
-pkgname=${_module}-git
-pkgver=1.13.9.7e028a5
+_pkgname=spnego-http-auth-nginx-module
+pkgname=${_pkgname}-git
+pkgver=1.18.0.72c8ee0
+_nginxver=1.18.0
pkgrel=1
pkgdesc='Dynamic Nginx module for SPNEGO Kerberos authentication via GSSAPI'
arch=('x86_64')
url='https://github.com/stnoonan/spnego-http-auth-nginx-module'
license=('BSD')
depends=('nginx' 'krb5')
-source=("${pkgname}::git+https://github.com/stnoonan/${_module}.git"
- "https://nginx.org/download/nginx-${_nginx}.tar.gz"
- "https://nginx.org/download/nginx-${_nginx}.tar.gz.asc")
+source=("${pkgname}::git+https://github.com/stnoonan/${_pkgname}.git"
+ "https://nginx.org/download/nginx-${_nginxver}.tar.gz"
+ "https://nginx.org/download/nginx-${_nginxver}.tar.gz.asc")
sha256sums=('SKIP'
- 'SKIP'
+ '4c373e7ab5bf91d34a4f11a0c9496561061ba5eee6020db272a17a7228d35f99'
'SKIP')
validpgpkeys=('B0F4253373F8F6F510D42178520A9993A1C052F8') # Maxim Dounin <mdounin@mdounin.ru>
pkgver() {
cd "${srcdir}/${pkgname}"
- echo "${_nginx}".$(git rev-parse --short HEAD)
+ echo "${_nginxver}".$(git rev-parse --short HEAD)
}
build() {
- cd "${srcdir}/nginx-${_nginx}"
+ cd "${srcdir}/nginx-${_nginxver}"
./configure --with-compat --add-dynamic-module=../"${pkgname}"
make modules
}
package() {
cd "${srcdir}"
- install -Dm755 "nginx-${_nginx}"/objs/ngx_http_auth_spnego_module.so "${pkgdir}"/usr/lib/nginx/modules/ngx_http_auth_spnego_module.so
+ install -Dm755 "nginx-${_nginxver}"/objs/ngx_http_auth_spnego_module.so "${pkgdir}"/usr/lib/nginx/modules/ngx_http_auth_spnego_module.so
install -Dm644 "${pkgname}"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
}