summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBert Peters2019-02-26 11:17:07 +0100
committerBert Peters2019-02-26 11:17:58 +0100
commit6db122a7196a8adbc40965908454033e8fccb8b2 (patch)
tree559053a01fdb8415408a6991d547dcb0fad2f71f /PKGBUILD
parent4d6bd477ea31ea4aba467f1f1d8fdb4a8b485d69 (diff)
downloadaur-6db122a7196a8adbc40965908454033e8fccb8b2.tar.gz
Update to 0.2.5.
Also include the DBUS dependency. It's not technically needed since DBUS is a direct dependency of systemd, but there's also no harm in adding it and namcap likes it.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 510f638f8889..953f8c006a74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,16 @@
pkgbase=spotifyd
pkgname=('spotifyd' 'spotifyd-pulseaudio' 'spotifyd-dbus-mpris')
-pkgver=0.2.4
+pkgver=0.2.5
pkgrel=1
arch=('x86_64' 'armv7h' 'aarch64')
license=('GPL3')
depends=('alsa-lib' 'libogg' 'gcc-libs')
-makedepends=('cargo' 'libpulse')
+makedepends=('cargo' 'libpulse' 'dbus')
pkgdesc="A spotify playing daemon"
url="https://github.com/Spotifyd/$pkgbase"
source=("$pkgbase-$pkgver.tar.gz::https://github.com/Spotifyd/$pkgbase/archive/v$pkgver.tar.gz")
-sha256sums=('05359f6b9e93cd64c3dfada42341dd3b3999f7d695093f5e831164016b945dd3')
+sha256sums=('dfaca1e382b11197e11941388734dddb7dae4ec44ad36aaf78f76b4011102b53')
prepare() {
cd "$srcdir/spotifyd-$pkgver"
@@ -47,6 +47,7 @@ package_spotifyd-pulseaudio() {
}
package_spotifyd-dbus-mpris() {
+ depends=(alsa-lib libogg dbus)
conflicts=(spotifyd)
pkgdesc="$pkgdesc, with D-Bus MPRIS"
_package_feature dbus_mpris