summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBert Peters2018-10-04 15:40:42 +0200
committerBert Peters2018-10-04 15:40:42 +0200
commitddb647d41f5dee4a1100e074782e388fd16286dc (patch)
tree4dfc573575b4c956fb69d3b609179ee7366950f1 /PKGBUILD
parent1fff90f46ca28bb2ff800518475cd4ed8841c053 (diff)
downloadaur-ddb647d41f5dee4a1100e074782e388fd16286dc.tar.gz
Fix OpenSSL compatibility issue.
See: https://github.com/Spotifyd/spotifyd/issues/173
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dc517149a4f..1d49919868bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,28 @@
pkgbase=spotifyd
pkgname=('spotifyd' 'spotifyd-pulseaudio')
pkgver=0.2.2
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'armv7h' 'aarch64')
license=('GPL3')
depends=('alsa-lib' 'libogg' 'gcc-libs')
makedepends=('cargo' 'libpulse')
pkgdesc="A spotify playing daemon"
url="https://github.com/Spotifyd/$pkgbase"
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/Spotifyd/$pkgbase/archive/v$pkgver.tar.gz")
-sha256sums=('6b79072efbfe1f3c831e898da2c340d806f778d598e6797347e5605d2201ec43')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/Spotifyd/$pkgbase/archive/v$pkgver.tar.gz"
+ "version.patch"
+ "openssl.patch")
+sha256sums=('6b79072efbfe1f3c831e898da2c340d806f778d598e6797347e5605d2201ec43'
+ '54452a87cde087336771019a079e1470f13c5b48430ca940be576bf3cc057b84'
+ 'a91205a067b4c9a30a43d350abfb3d334fc35cad8556f4643373d3f7258d9c25')
+
+prepare() {
+ cd "$srcdir/spotifyd-$pkgver"
+ # Fix the wrong version being reported
+ patch -p1 < "$srcdir/version.patch"
+
+ # Fix not being able to compile with OpenSSL 1.1.0
+ patch -p1 < "$srcdir/openssl.patch"
+}
build() {
cd "$srcdir/spotifyd-$pkgver"