summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntoine Viallon2020-06-30 11:29:14 +0200
committerAntoine Viallon2020-06-30 11:29:49 +0200
commitc4410b71b8e17efdff86525fef2dd81a86bb36a2 (patch)
tree840758600b64da8be774d4256c1ca7e9b6b3f972 /PKGBUILD
downloadaur-spotrec-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a514c3dda41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Antoine Viallon <antoine@lesviallon.fr>
+
+pkgname=spotrec-git
+pkgver=v0.12.0.r2.g15c2e71
+pkgrel=1
+pkgdesc="Spotify desktop client recorder for PulseAudio (git version)"
+arch=('any')
+url="https://github.com/Bleuzen/SpotRec"
+license=('mit')
+depends=('python' 'python-dbus' 'ffmpeg' 'gawk' 'bash')
+optdepends=('spotify'
+ 'audacity'
+ 'kid3')
+source=("${pkgname}::git+${url}")
+sha256sums=('SKIP')
+provides=(spotrec)
+conflicts=(spotrec)
+makedepends=(nuitka)
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ ./build.sh
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin/
+ install -D $pkgname/spotrec "$pkgdir"/usr/bin/
+}