summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122015-09-16 15:21:38 +0200
committerwillemw122015-09-16 15:21:38 +0200
commit5cdeed2b001756d9bfab47266e28c83f05009d3e (patch)
tree09232b6ea08d4f07d45be0dfa1d7153da28245ab /PKGBUILD
parent59fe9b6aee449f6370e22ecf6d5aadb3012e50c0 (diff)
downloadaur-5cdeed2b001756d9bfab47266e28c83f05009d3e.tar.gz
Fix 'provides' and 'conflicts'
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5571c7d33090..85e2d424c9ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname2=spyder
_pkgname3=spyder3
pkgbase=$_pkgname2-git
pkgname=($_pkgname2-git $_pkgname3-git)
-pkgver=3.0.0b1.r134.g2e7699b
+pkgver=3.0.0b1.r145.gb1d9780
pkgrel=1
arch=('any')
url="https://github.com/spyder-ide/spyder"
@@ -54,15 +54,14 @@ package_spyder-git() {
'python2-matplotlib: interactive 2D/3D data plotting'
'pep8-python2: real-time code style analysis'
'python2-sympy: symbolic mathematics for the IPython console')
- _pkgname='spyder'
- provides=($_pkgname)
- conflicts=($_pkgname)
+ provides=($_pkgname2)
+ conflicts=($_pkgname2)
- cd $_pkgname
+ cd $_pkgname2
python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
# Install a scalable icon for the spyder.desktop file
install -Dm644 spyderlib/images/spyder.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/spyder.svg"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname2/LICENSE"
rm "$pkgdir/usr/bin/spyder_win_post_install.py"
}
@@ -82,15 +81,14 @@ package_spyder3-git() {
'python-matplotlib: interactive 2D/3D data plotting'
'pep8: real-time code style analysis'
'python-sympy: symbolic mathematics for the IPython console')
- _pkgname='spyder3'
- provides=($_pkgname)
- conflicts=($_pkgname)
+ provides=($_pkgname3)
+ conflicts=($_pkgname3)
- cd $_pkgname
+ cd $_pkgname3
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
# Install a scalable icon for the spyder3.desktop file
install -Dm644 spyderlib/images/spyder.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/spyder3.svg"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname3/LICENSE"
rm "$pkgdir/usr/bin/spyder_win_post_install.py"
}