summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Gregoratto2019-01-12 00:08:26 +1100
committerStephen Gregoratto2019-01-12 00:08:26 +1100
commit995d098f4b01062072734adad0e94a668e587d5b (patch)
treeadaa2487d4d611de38e06c98bfd0e348c492afe1 /PKGBUILD
parent934bd4c19d5d9a3d35623bab5b9165516250e37f (diff)
downloadaur-sqawk-git.tar.gz
Change pkgver/epoch, enable upstream testing, simplify stages.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 18 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f204cd621c92..87376296e2d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,38 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
-
+# Maintainer: KingofToasters <themanhimself at sgregoratto dot me>
+# Contributor: Andy Weidenbaum <archbaum at gmail dot com>
pkgname=sqawk-git
-pkgver=20160510
+epoch=1
+pkgver=r184.658b628
pkgrel=1
pkgdesc="Like Awk but with SQL and table joins"
-arch=('i686' 'x86_64')
-depends=('sqlite-tcl' 'tcl' 'tcllib')
-makedepends=('git')
url="https://github.com/dbohdan/sqawk"
license=('MIT')
-source=(git+https://github.com/dbohdan/sqawk)
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+depends=('sqlite-tcl' 'tcl' 'tcllib')
+makedepends=('git')
+source=("${pkgname%-git}::git+$url")
sha256sums=('SKIP')
pkgver() {
cd ${pkgname%-git}
- git log -1 --format="%cd" --date=short --no-show-signature | sed "s|-||g"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
cd ${pkgname%-git}
-
- msg2 'Building...'
make
}
-package() {
+check() {
cd ${pkgname%-git}
+ make test
+}
- msg2 'Installing license...'
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
-
- msg2 'Installing documentation...'
- install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-git}"
- cp -dpr --no-preserve=ownership examples \
- "$pkgdir/usr/share/doc/${pkgname%-git}"
-
- msg2 'Installing...'
+package() {
+ cd ${pkgname%-git}
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}"
+ install -d "$pkgdir/usr/share/doc/${pkgname%-git}"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/${pkgname%-git}/README"
+ cp -dpr --no-preserve=ownership examples "$pkgdir/usr/share/doc/${pkgname%-git}"
make prefix=/usr DESTDIR="$pkgdir" install
-
- msg2 'Cleaning up pkgdir...'
- find "$pkgdir" -type d -name .git -exec rm -r '{}' +
}