summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabius2019-09-07 17:40:23 +0200
committerFabius2019-09-07 17:40:23 +0200
commitf70b86d7667ddf8d26d6e68ee2b26a1e84c785be (patch)
tree0041ea983e57f6ab226fb6f723914f908da21227 /PKGBUILD
parente950679252c4fd2c20e5a6890bc801fd6aef60ec (diff)
downloadaur-sqlint.tar.gz
Fixed dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 805ac40aa129..9b4728fa922d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: Fabius
# Contributor: Stefan Heinemann <stefan.heinemann@codedump.ch>
-_pkgname=sqlint
+_gemname=sqlint
pkgname=sqlint
pkgver=0.1.9
-pkgrel=1
+pkgrel=2
pkgdesc="Simple SQL linter supporting ANSI and PostgreSQL syntaxes"
arch=(any)
url="https://github.com/purcell/sqlint"
license=('MIT')
-makedepends=("rubygems")
-depends=("ruby-pg-query")
-source=("https://rubygems.org/downloads/$_pkgname-$pkgver.gem")
-noextract=("$_pkgname-$pkgver.gem")
+makedepends=('rubygems')
+depends=('ruby' 'ruby-pg-query')
+optdepends=()
+source=("https://rubygems.org/downloads/$_gemname-$pkgver.gem")
+noextract=("$_gemname-$pkgver.gem")
sha256sums=("7e5a28eac136c16546d9bae94955501b3f0e39d27422fc6be01588c20160e9dd")
-
package() {
- local _gemdir="$(ruby -r rubygems -e"puts Gem.default_dir")"
- gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" "$_pkgname-$pkgver.gem"
- install -D "$pkgdir$_gemdir/gems/$_pkgname-$pkgver/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" "$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
}