summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGötz Christ2022-09-12 07:43:48 -0500
committerGötz Christ2022-09-12 07:51:59 -0500
commit02689fbd4830d80d984e9ffdb43d975fcfb9bdde (patch)
treeb20840bb226289383022071f14d95c55467b237a /PKGBUILD
parent39749783685d06c277050763f18a1b22bc636edb (diff)
downloadaur-squishyball.tar.gz
Update to r78.27590fe (Thanks afontenot)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5fa4b5d9f64..358126b7fa2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,40 @@
# Maintainer: goetzc
# Contributor: Gaetan Bisson <bisson@archlinux.org
+# Contributor: afontenot
pkgname=squishyball
-pkgver=19643
+pkgver=r78.27590fe
pkgrel=1
pkgdesc='Perform ABX audio sample comparison testing on the command line'
-url='https://svn.xiph.org/trunk/squishyball/'
+url='https://gitlab.xiph.org/xiph/squishyball'
arch=('i686' 'x86_64')
license=('GPL2')
-makedepends=('subversion')
depends=('opusfile' 'ncurses' 'libvorbis' 'flac' 'libao')
-source=("svn+https://svn.xiph.org/trunk/squishyball/")
-sha1sums=('SKIP')
+source=("git+https://gitlab.xiph.org/xiph/squishyball.git"
+ "https://gitlab.xiph.org/xiph/squishyball/uploads/5609ceaf85ebb6dc297c0efe61b9a1b7/0001-mincurses.c-use-ncurses-API-to-enter-raw-mode-ncurse.patch")
-prepare() {
- cd "${srcdir}/${pkgname}"
- # Fix compile, from Debian bug tracker #860334
- sed -i '/#define _FILE_OFFSET_BITS/a#define NCURSES_INTERNALS' mincurses.c
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pkgver() {
- cd "${srcdir}/${pkgname}"
- svn info | awk '/Revision/{print $2}'
+prepare() {
+ cd "$pkgname"
+ # fix building against ncurses-6.3+
+ patch -Np1 -i "$srcdir/0001-mincurses.c-use-ncurses-API-to-enter-raw-mode-ncurse.patch"
}
build() {
- cd "${srcdir}/${pkgname}"
+ cd "$pkgname"
sed -i 's:@MANDIR@:/usr/share/man:' Makefile.am
./autogen.sh --prefix='/usr'
make
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "$pkgname"
make DESTDIR="${pkgdir}" install
}
+
+sha256sums=('SKIP'
+ '9eb5e820069867a6b36c06b71b941d5c82aff6bd0f966be588cbcf203e29aae6')