summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhr33d0m2023-11-17 20:00:04 +0100
committerPhr33d0m2023-11-17 20:00:04 +0100
commit93c47af77fe4969f730f74c400ffa56d9c39faaf (patch)
treee2b16c18fe80fe7bdc449dde8df084a40c9dedf7 /PKGBUILD
downloadaur-sshed-bin.tar.gz
v1.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7b90340e583
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Phr33d0m <archlinux at ne-davam.info>
+
+pkgname=sshed-bin
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Visual cross-platform editor created to manage list of SSH hosts in ssh config file"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://github.com/trntv/sshed"
+license=('Apache')
+source_x86_64=("https://github.com/trntv/sshed/releases/download/$pkgver/sshed_${pkgver}_linux_amd64.tar.gz")
+source_i686=("https://github.com/trntv/sshed/releases/download/$pkgver/sshed_${pkgver}_linux_386.tar.gz")
+source_armv6h=("https://github.com/trntv/sshed/releases/download/$pkgver/sshed_${pkgver}_linux_armv6.tar.gz")
+source_armv7h=("https://github.com/trntv/sshed/releases/download/$pkgver/sshed_${pkgver}_linux_armv7.tar.gz")
+sha256sums_x86_64=('2a2671ba7b5462a557660d21a863cb565ffe79a53bab124bb4b1cd84b1d8c164')
+sha256sums_i686=('da5a1a44f642f725ef7b6dcded48d5510241e8e404e9d15efc2e513e797804fb')
+sha256sums_armv6h=('5c4fcd5c128e8f04bcd01f01b6665c9f61dabe825cc1c13b4e2b5dfc9ecfb3ad')
+sha256sums_armv7h=('213fbeb9c04d08c40c32065f60cc5a82b547b20cc5bfeddc569ee3f34e26ae79')
+
+package() {
+ cd "$srcdir"
+ install -Dm755 sshed "$pkgdir/usr/bin/sshed"
+}