summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgrsakea2017-10-08 18:55:28 +0200
committergrsakea2017-10-08 19:07:34 +0200
commitc3a523f4d8a512155e885c0ebb292a3d8dbf299e (patch)
tree4a60c163ff83e43f8c5088ccb1d7e267a8b12ffd /PKGBUILD
parenta148393242d40e0d28d5f1216962c543cbcc6b1f (diff)
downloadaur-c3a523f4d8a512155e885c0ebb292a3d8dbf299e.tar.gz
Add homemade modification
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD75
1 files changed, 39 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d9b4dfcdf42..3e8f02b1c45b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Past Maintainer: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Scytrin dai Kinthra <scytrin@gmail.com>
-pkgname=st-git
+pkgname=st-git-hm
_pkgname=st
-pkgver=0.7.9.g8c99915
+pkgver=0.7.37.gb1338e9
pkgrel=1
pkgdesc='Simple virtual terminal emulator for X'
url='http://st.suckless.org/'
@@ -15,52 +15,55 @@ depends=('libxft')
makedepends=('ncurses' 'libxext' 'git')
epoch=1
# include config.h and any patches you want to have applied here
-source=('git://git.suckless.org/st')
-sha1sums=('SKIP')
+source=('git+https://git.suckless.org/st'
+'https://st.suckless.org/patches/solarized/st-no_bold_colors-20170623-b331da5.diff'
+'https://st.suckless.org/patches/solarized/st-solarized-dark-20170623-b331da5.diff'
+)
+sha1sums=('SKIP'
+'SKIP'
+'SKIP')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
pkgver() {
- cd "${_pkgname}"
- git describe --tags |sed 's/-/./g'
+ cd "${_pkgname}"
+ git describe --tags |sed 's/-/./g'
}
prepare() {
- local file
- cd "${_pkgname}"
- sed \
- -e '/char font/s/= .*/= "Fixed:pixelsize=13:style=SemiCondensed";/' \
- -e '/char worddelimiters/s/= .*/= " '"'"'`\\\"()[]{}<>|";/' \
- -e '/int defaultcs/s/= .*/= 1;/' \
- -i config.def.h
- sed \
- -e 's/CPPFLAGS =/CPPFLAGS +=/g' \
- -e 's/CFLAGS =/CFLAGS +=/g' \
- -e 's/LDFLAGS =/LDFLAGS +=/g' \
- -e 's/_BSD_SOURCE/_DEFAULT_SOURCE/' \
- -i config.mk
- sed '/@tic/d' -i Makefile
- for file in "${source[@]}"; do
- if [[ "$file" == "config.h" ]]; then
- # add config.h if present in source array
- # Note: this supersedes the above sed to config.def.h
- cp "$srcdir/$file" .
- elif [[ "$file" == *.diff || "$file" == *.patch ]]; then
- # add all patches present in source array
- patch -Np1 <"$srcdir/$(basename ${file})"
- fi
- done
+ local file
+ cd "${_pkgname}"
+ for file in "${source[@]}"; do
+ if [[ "$file" == *.diff || "$file" == *.patch ]]; then
+ echo $file
+ # add all patches present in source array
+ patch -Np1 <"$srcdir/$(basename ${file})"
+ fi
+ done
+
+ sed \
+ -e '/char font/s/= .*/= "Inconsolata for Powerline:size=11";/' \
+ -e '/char worddelimiters/s/= .*/= " '"'"'`\\\"()[]{}<>|│";/' \
+ -e 's/TERMMOD, XK_Y,/ShiftMask, XK_Insert,/' \
+ -i config.def.h
+ sed \
+ -e 's/CPPFLAGS =/CPPFLAGS +=/g' \
+ -e 's/CFLAGS =/CFLAGS +=/g' \
+ -e 's/LDFLAGS =/LDFLAGS +=/g' \
+ -e 's/_BSD_SOURCE/_DEFAULT_SOURCE/' \
+ -i config.mk
+ sed '/@tic/d' -i Makefile
}
build() {
- cd "${_pkgname}"
- make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+ cd "${_pkgname}"
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
}
package() {
- cd "${_pkgname}"
- make PREFIX=/usr DESTDIR="${pkgdir}" install
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
+ cd "${_pkgname}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
}