summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcropinghigh2022-03-27 14:55:17 +0300
committercropinghigh2022-03-27 14:55:17 +0300
commitd40a65c0a4481db8a147fce8d642386051b3a377 (patch)
treeda74e58d644970b5523afe900a5d4a0210ef9de7 /PKGBUILD
parent3748edf73e742eed904f8eb3e15600ee4ec4502d (diff)
downloadaur-stdcdec-git.tar.gz
update version code + git protocol
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3632fd2200e3..2eca4341b933 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,21 @@
# Stdcdec program to demodulate, decode and parse Inmarsat-C signals
# Maintainer: cropinghigh <joinmark60@gmail.com>
pkgname=stdcdec-git
-pkgver=1.0
+pkgver=r11.c9a1689
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Stdcdec program to demodulate, decode and parse Inmarsat-C signals"
license=('GPL')
depends=("libinmarsatc")
provides=("stdcdec")
-source=("git://github.com/cropinghigh/stdcdec")
+source=("git+https://github.com/cropinghigh/stdcdec")
md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/stdcdec"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
cd $srcdir/stdcdec
mkdir build