summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOrhun Parmaksız2021-11-24 22:56:09 +0300
committerOrhun Parmaksız2021-11-24 22:56:09 +0300
commit6893cf321fc8fb791ac4cb60f3042246945ef556 (patch)
tree5a3ed4936748556cf280df324fde66288cd701c3 /PKGBUILD
parent4b3699934b630268beb925bdfa85101e2047078c (diff)
downloadaur-stegify-git.tar.gz
upgpkg: stegify-git 1.2.r2.g62518ca-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e003d227b65..8be014c27203 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=stegify-git
pkgdesc="Tool for LSB steganography written in Go (git)"
pkgver=1.2.r2.g62518ca
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="https://github.com/DimitarPetrov/stegify"
license=('MIT')
@@ -26,7 +26,8 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go get -d ./...
+ go mod init github.com/DimitarPetrov/stegify
+ go get github.com/DimitarPetrov/stegify/steg
go build -o "${pkgname%-git}" .
}