summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Hodgetts2018-06-06 18:28:12 +0100
committerBenjamin Hodgetts2018-06-06 18:28:12 +0100
commitbadcf02e5808065304a4e388e32488751166178a (patch)
tree1e2a25c5e2ad6d6cad52fbe2b850023eff7cd81b /PKGBUILD
downloadaur-stm32flash-ex-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c13de9bfb2fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Benjamin Hodgetts <ben@xnode.org>
+# Contributor: Andrey Tkachenko <andreytkachenko64@gmail.com>
+
+_pkgname=stm32flash
+pkgname=stm32flash-ex-git
+pkgver=r351.5ad1f87
+pkgrel=1
+pkgdesc='Open source flash program for the STM32 ARM processors using the ST serial bootloader over UART or I2C (fixed)'
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+url='http://git.code.sf.net/p/stm32flash/code'
+license=('GPLv2')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git://git.code.sf.net/p/stm32flash/code")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ make
+}
+
+package() {
+ # executable
+ cd $_pkgname
+ install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
+}