summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-04-13 16:44:29 +0800
committerChocobo12023-04-13 16:44:29 +0800
commit9700207d326a608ac55722f77d0d7725d9199fb9 (patch)
treed44c9c0fab0048f4feb97cb359e3b3dd2485fdc5 /PKGBUILD
parentc070af1a796f3a26ea1755372cdf63f5c2eaa964 (diff)
downloadaur-strace-git.tar.gz
upgpkg: strace-git 6.2.r12.gd3b97fce7-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f1f18c206e8..fb6164435f67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=strace-git
-pkgver=4.19.r9.gd45f2714
+pkgver=6.2.r12.gd3b97fce7
pkgrel=1
pkgdesc="A diagnostic, debugging and instructional utility"
arch=('i686' 'x86_64')
@@ -10,7 +10,7 @@ license=('BSD')
depends=('glibc' 'libunwind')
optdepends=('perl')
makedepends=('git')
-provides=('strace')
+provides=("strace=$pkgver")
conflicts=('strace')
source=("git+https://github.com/strace/strace.git")
sha256sums=('SKIP')
@@ -26,7 +26,9 @@ build() {
cd "strace"
./bootstrap
- ./configure --prefix="/usr" --with-libunwind
+ ./configure \
+ --prefix="/usr" \
+ --with-libunwind
make
}
@@ -40,5 +42,5 @@ package() {
cd "strace"
make DESTDIR="$pkgdir" install
- install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/strace/COPYING"
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/strace"
}