summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBarbUk2021-06-16 15:46:27 +0400
committerBarbUk2021-06-16 15:46:27 +0400
commit565cd2df65dd32cfec5e7ef9e55d223027bcfa13 (patch)
tree02ebd705c2ae45a7fb250f809d1bd1871229d483 /PKGBUILD
downloadaur-strace-parser-bin.tar.gz
First bin release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa92a2195982
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Julien Virey <julien.virey@gmail.com>
+
+pkgname=strace-parser-bin
+pkgver=0.7.2
+pkgrel=1
+_tag=aeec995aa6d28ce0ddc5e8dab3952278
+pkgdesc='Strace parser written in Rust'
+arch=(x86_64)
+url=https://gitlab.com/gitlab-com/support/toolbox/strace-parser
+license=(MIT)
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("$url/uploads/$_tag/${pkgname%-bin}_${pkgver//./-}_linux_musl.tar.gz")
+sha256sums=('885dfc3ea2b5dcbef16a71c33ef992d858abd9a64a1dc59375f5d425e86b1a05')
+
+package() {
+ install -Dm755 "${pkgname%-bin}" "$pkgdir/usr/bin/${pkgname%-bin}"
+}