summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYuval Adam2019-11-21 18:25:12 +0200
committerYuval Adam2019-11-21 18:28:29 +0200
commit354670b8a397188819c490b239e6d9b5ce63233c (patch)
treeb3908a73a25d8a6a805d9af45ce4394131dcad83 /PKGBUILD
downloadaur-streamlib.tar.gz
Add initial streamlib package v0.6.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a08c64b7c5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Yuval Adam <aur at yuv dot al> PGP-Key: 55E36E28535222E2A2062848B75B5FC2FA1AFE15
+
+pkgname=streamlib
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="Play your favorite live streams from command line"
+arch=('any')
+url="https://github.com/streamlib/streamlib"
+license=(GPL)
+makedepends=('cargo')
+source=("https://github.com/streamlib/streamlib/archive/v${pkgver}.tar.gz")
+sha1sums=('1373356032f9f1f7c4454daab7a815747e1dbe78')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cargo build --release
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 "target/release/streamlib" "$pkgdir/usr/bin/streamlib"
+}
+
+# vim:set ts=2 sw=2 et: