summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2017-10-03 23:08:12 +0200
committerCarsten Teibes2017-10-03 23:08:12 +0200
commit0a947ac2442e5b8e09457f429e119e55a8e1aeda (patch)
treed51fb5cbef4b3cc1172332d6418150ae21765903 /PKGBUILD
parent3d5d2e1bf94c5075a40b4f1f5f5d4bca46aa5e3f (diff)
downloadaur-sublime-text2.tar.gz
[fix] Cleanup and rename to sublime-text2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 21 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3f92a97ed00..b3a9ffa5c48c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,15 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-# Contributor: Josh Kropf <josh@slashdev.ca>
-# Contributor: Bartosz Chmura <chmurli at gmail dot com>
-# Contributor: Mikkel Kroman <mk at maero dot dk>
-pkgname=sublime-text
+pkgname=sublime-text2
pkgver=2.0.2
-pkgrel=4
-pkgdesc="Sophisticated text editor for code, html and prose"
+pkgrel=1
+pkgdesc="Sophisticated text editor for code, html and prose (legacy version)"
arch=('i686' 'x86_64')
-url="http://www.sublimetext.com/2"
-license=('custom')
-depends=("libpng" "gtk2" "bash" "procps-ng" "xdg-utils" "desktop-file-utils"
- "shared-mime-info")
-install="$pkgname.install"
- # EULA file is from http://www.sublimetext.com/eula
- # converted with 'html2text --ignore-links --body-width=80'
+url="https://www.sublimetext.com/2"
+license=('custom: commercial')
+depends=("libpng" "gtk2" "bash" "xdg-utils" "desktop-file-utils" "shared-mime-info")
+conflicts=("sublime-text")
+ # EULA file: 'html2text --body-width=80 https://www.sublimetext.com/eula'
source=("$pkgname-EULA"
"$pkgname.desktop"
"$pkgname.sh"
@@ -23,11 +18,11 @@ source=("$pkgname-EULA"
"0001-libpng16-Avoid-dereferencing-NULL-pointer-possibly-r.patch"
"0002-libpng16-Calculate-our-own-zlib-windowBits-when-deco.patch"
"adjust-apng-patch-for-libpng16-git-changes.patch")
-source_i686=("http://c758482.r82.cf2.rackcdn.com/Sublime%20Text%20${pkgver}.tar.bz2")
-source_x86_64=("http://c758482.r82.cf2.rackcdn.com/Sublime%20Text%20${pkgver}%20x64.tar.bz2")
-sha256sums=('43aa2cf3becee23697177c6e6ecd4fc2c4b459499631bfdb2533cdb60c27530e'
- '3f11bf8cb814b68ed81b535dd13cc86bb28c71010d74141bfa06137782fd2f7d'
- '765c8a65ef429dc81a983d14d94c97a2d185575d74e702861ad3e374e2759338'
+source_i686=("https://download.sublimetext.com/Sublime%20Text%20${pkgver}.tar.bz2")
+source_x86_64=("https://download.sublimetext.com/Sublime%20Text%20${pkgver}%20x64.tar.bz2")
+sha256sums=('dec26169ec941f1089810b7be599193577d0250f20e465d1399b062f71f2a244'
+ '7a3d0ea23fc0eb8d1e4d322df96a18aab214f8f7ef5808a60f9ad4866c0fc14b'
+ '153cfa48f8f058cba03e30aa39dc90d9b9ab1d07ce9bfb3bceb78b2c699c47e8'
'1c97a90bc22107e50f04f77a0115f4ec890d5c6a373ac4c560e8fb87259e92de'
'4196f3c3894f455a78a65170209fc948b01a7448304d8c39bc29d37852b8c73b'
'0632ea1d588cb7b85dfc2c13444de1682e9d7e61caaf8cce118fc535bc9f4d90'
@@ -40,29 +35,29 @@ prepare() {
# libpng
rm -rf png_fake_install
mkdir png_fake_install
+ patch -Np0 < adjust-apng-patch-for-libpng16-git-changes.patch
cd libpng-1.6.2
patch -Np1 < ../0001-libpng16-Avoid-dereferencing-NULL-pointer-possibly-r.patch
- patch -Np1 -i ../0002-libpng16-Calculate-our-own-zlib-windowBits-when-deco.patch
- patch -d .. -Np0 < ../adjust-apng-patch-for-libpng16-git-changes.patch
+ patch -Np1 < ../0002-libpng16-Calculate-our-own-zlib-windowBits-when-deco.patch
patch -Np1 < ../libpng-1.6.2-apng.patch
}
build() {
# libpng
cd libpng-1.6.2
- ./configure --prefix=/ --with-binconfigs=no --enable-shared --disable-static
+ ./configure --prefix=/ --without-binconfigs --enable-shared --disable-static
make install DESTDIR="$srcdir"/png_fake_install
}
package () {
install -d "$pkgdir"/opt
- cp -rup "Sublime Text 2" "$pkgdir"/opt/$pkgname
+ cp -r "Sublime Text 2" "$pkgdir"/opt/$pkgname
# launcher
- install -Dm755 $pkgname.sh "$pkgdir"/usr/bin/subl
+ install -Dm0755 $pkgname.sh "$pkgdir"/usr/bin/subl
# .desktop file and icons
- install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -Dm0644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
for _res in 256x256 128x128 48x48 32x32 16x16; do
install -d "$pkgdir"/usr/share/icons/hicolor/$_res/apps
ln -s /opt/$pkgname/Icon/$_res/sublime_text.png \
@@ -70,10 +65,10 @@ package () {
done
# license
- install -Dm644 $pkgname-EULA "$pkgdir"/usr/share/licenses/$pkgname/EULA
+ install -Dm0644 $pkgname-EULA "$pkgdir"/usr/share/licenses/$pkgname/EULA
# libpng
- install -m644 png_fake_install/lib/libpng16.so.16.2.0 \
+ install -m0644 png_fake_install/lib/libpng16.so.16.2.0 \
"$pkgdir"/opt/$pkgname/lib/libpng16.so.16.2.0
ln -s libpng16.so.16.2.0 "$pkgdir"/opt/$pkgname/lib/libpng16.so.16
ln -s libpng16.so.16 "$pkgdir"/opt/$pkgname/lib/libpng16.so