summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGötz Christ2017-10-07 14:18:26 -0500
committerGötz Christ2017-10-07 14:18:26 -0500
commite9797f88e8fc3a14b2354c185eecfe9634396b60 (patch)
treea58ca411940379eea18460e4c7a304115a2ab1db /PKGBUILD
parentab3bd150cbe2711bfad98793dbc03ea9259458f6 (diff)
downloadaur-subtitleeditor-git.tar.gz
Upstream moved to git
Some cleanups
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4d7ff0400d4..e68933888f71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
-pkgname=subtitleeditor-svn
-pkgver=0.52.1.r952
+# Maintainer: goetzc
+pkgname=subtitleeditor-git
+pkgver=0.54.0.r12.g3a66a9a
pkgrel=1
pkgdesc="GTK+3 tool to create and edit subtitles."
arch=('i686' 'x86_64')
-url="http://home.gna.org/subtitleeditor/"
+url="http://kitone.github.io/subtitleeditor/"
license=('GPL3')
-depends=('desktop-file-utils' 'enchant' 'gst-plugins-base' 'gst-libav' 'gstreamermm>=1.0'
- 'gtk3' 'gtkmm3' 'hicolor-icon-theme' 'libsigc++' 'libxml++' 'xdg-utils')
-#makedepends=('svn' 'intltool' 'mm-common')
+depends=('enchant' 'gst-plugins-base' 'gst-libav'
+ 'gstreamermm>=1.0' 'gtkmm3' 'libxml++2.6')
+makedepends=('intltool')
optdepends=('gst-plugins-ugly: to be able to view movies inside the subtitleeditor')
provides=(${pkgname%-*})
conflicts=(${pkgname%-*})
-source=('subtitleeditor-svn::svn+http://svn.gna.org/svn/subtitleeditor/trunk')
+source=('subtitleeditor-git::git+https://github.com/kitone/subtitleeditor.git')
sha256sums=('SKIP')
pkgver() {
cd $pkgname
- local ver="$(svnversion)"
- printf "0.52.1.r%s" "${ver//[[:alpha:]]}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -32,3 +32,4 @@ package() {
make DESTDIR=${pkgdir} install
}
+