summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIvan Shapovalov2020-05-27 02:34:36 +0300
committerIvan Shapovalov2020-05-27 02:34:36 +0300
commitdfc0a9121e9ef8956f0d3a3b3ad31ac38ad843ba (patch)
treeaa85bcaa224d839a7f3ab74f8e4daa06209fbeb7 /PKGBUILD
parente9a2c83a92ae3d09733fdae1c0b9646f3369ed4c (diff)
downloadaur-superiotool-git.tar.gz
Coreboot moved to Git; follow along.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d46aecfc9f31..29acd481065f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,40 @@
-# Maintainer: Ivan Shapovalov <intelfx100@gmail.com>
+# Maintainer: Ivan Shapovalov <intelfx@intelfx.name>
-pkgname=superiotool-svn
+pkgname=superiotool-git
epoch=1
-pkgver=r6637
+pkgver=4.11.r2679.g1afe2863678
pkgrel=1
pkgdesc="Detects the Super I/O of your mainboard and provides information about its register contents"
arch=(i686 x86_64)
url="http://www.coreboot.org/Superiotool"
license=(GPL)
-makedepends=(subversion)
-source=(svn://coreboot.org/coreboot/trunk/util/superiotool)
+makedepends=('git')
+provides=('superiotool')
+replaces=('superiotool-svn')
+source=('git+https://review.coreboot.org/coreboot')
md5sums=(SKIP)
pkgver() {
- cd superiotool
+ cd coreboot/util/superiotool
- local ver="$(svnversion)"
- printf "r%s" "${ver//[[:alpha:]]}"
+ git describe --long $(git rev-list -1 HEAD .) | sed 's/-/.r/;s/-/./'
}
prepare() {
- cd superiotool
+ cd coreboot/util/superiotool
# Makefile is broken #1
sed -re 's|/sbin|/bin|' -i Makefile
}
build() {
- cd superiotool
+ cd coreboot/util/superiotool
make
}
package() {
- cd superiotool
+ cd coreboot/util/superiotool
make PREFIX=/usr DESTDIR="$pkgdir" install
}