summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHurricanePootis2024-04-05 21:21:38 -0500
committerHurricanePootis2024-04-05 21:21:38 -0500
commit0cc21d979552bc5a866bf516d41a5d95485cd175 (patch)
tree68767f82e8eee18457b48a25891b90a56b5dd68a /PKGBUILD
parente3c0473f88f51d488a915249ce5c1c988157e6bc (diff)
downloadaur-suyu-dev-qt6-git.tar.gz
Add back vcpkg submodule now that curl bug is fixed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64d68824a6cc..ff1f9e62ad50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=suyu
_branch=dev
pkgname=suyu-dev-qt6-git
-pkgver=r27347.d3f67d1e9c
+pkgver=r27354.b911ac8516
pkgrel=1
pkgdesc="suyu is the afterlife the world's most popular, open-source, Nintendo Switch emulator (dev branch with QT6)"
arch=(x86_64)
@@ -73,6 +73,7 @@ source=(
git+https://github.com/libsdl-org/SDL.git
git+https://github.com/yhirose/cpp-httplib.git
ffmpeg::git+https://github.com/FFmpeg/FFmpeg.git
+ git+https://github.com/microsoft/vcpkg.git
git+https://github.com/arun11299/cpp-jwt.git
git+https://github.com/bylaws/libadrenotools.git
git+https://github.com/lat9nq/tzdb_to_nx.git
@@ -114,6 +115,7 @@ b2sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -123,7 +125,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in {enet,cubeb,dynarmic,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,SDL,cpp-httplib,ffmpeg,cpp-jwt,libadrenotools,tzdb_to_nx,VulkanMemoryAllocator,breakpad,simpleini,oaknut,Vulkan-Utility-Libraries};
+ for submodule in {enet,cubeb,dynarmic,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,SDL,cpp-httplib,ffmpeg,vcpkg,cpp-jwt,libadrenotools,tzdb_to_nx,VulkanMemoryAllocator,breakpad,simpleini,oaknut,Vulkan-Utility-Libraries};
do
git config --file=.gitmodules submodule.$submodule.url "${srcdir}"/$submodule
done