summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgandalf32024-01-19 20:36:49 -0800
committergandalf32024-01-19 20:39:57 -0800
commit81c55dac8256a4639136f6bf944028ce2c658c3b (patch)
tree129ff063c74c736edc7c8b48b72132659d2c6cba /PKGBUILD
parentd191b74258b08782bb7a0e974f78f16a2c0637f2 (diff)
downloadaur-swami.tar.gz
update to 2.2.2
also: - removed patch for gobject-property-system - theres still references to srcdir in the built package, not sure how to fix that.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41b4e8118016..95f3857cb33f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# gandalf3 <gandalf3@blendermonkey.com>
pkgname=swami
-pkgver=2.2.1
+pkgver=2.2.2
pkgrel=1
pkgdesc='A SoundFont editor'
arch=('x86_64')
@@ -10,22 +10,18 @@ license=('GPL2')
depends=('gtk2' 'fftw' 'audiofile' 'fluidsynth' 'libinstpatch' 'libgnomecanvas')
makedepends=('cmake')
optdepends=('libpng')
-source=("https://github.com/swami/${pkgname}/archive/v${pkgver}.tar.gz" 'fix-2.2.x-for-gobject-property-system.patch')
-sha1sums=('8c5444c16f2837f1e89bf2ff717171e0d9ebb13d'
- 'd10ade9c2db31a7b771af1cd2178f2479615ddf4')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p 1 -i ../fix-2.2.x-for-gobject-property-system.patch
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/swami/${pkgname}/archive/v${pkgver}.tar.gz")
+sha1sums=('e7ac70719d55f66630677a2907e23389ddb5b5bf')
build() {
cd "${pkgname}-${pkgver}"
- cmake -D CMAKE_INSTALL_PREFIX=/usr .
+ cmake -Wno-dev -D CMAKE_SKIP_RPATH=YES\
+ -D CMAKE_BUILD_TYPE=Release\
+ -D CMAKE_INSTALL_PREFIX=/usr .
make
}
package() {
cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}/" install
+ make DESTDIR="${pkgdir}/" install/strip
}