summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author33KK2023-10-31 02:20:27 +0100
committer33KK2023-10-31 02:20:27 +0100
commit9c6f73dd7c1b29331c2cb1ed330b16056f84eaf5 (patch)
treea92ceb364a8047d3da04ec8c55aba8be39806626 /PKGBUILD
parent5371ac550507568ebf9b42eadd11960d58f840cb (diff)
downloadaur-sway-persistent-workspaces-git.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD98
1 files changed, 47 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64d60e9a39d4..088e9aa64074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,77 +1,73 @@
-# Maintainer: 33KK <hello@kkx.one>
+# Maintainer: 33KK <marko@pepega.club>
+# Contributor: GreyXor <greyxor@protonmail.com>
# Contributor: Drew DeVault <sir@cmpwn.com>
# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
-pkgname=sway-persistent-workspaces-git
+
_pkgname=sway
-pkgver=r6984.e40eb338
+pkgname="${_pkgname}-persistent-workspaces-git"
+pkgver=r7201.7efbd8e2
pkgrel=1
-license=("MIT")
-pkgdesc="Tiling Wayland compositor and replacement for the i3 window manager"
-makedepends=(
- "git"
- "meson"
- "scdoc"
- "wayland-protocols"
-)
+arch=('x86_64')
+pkgdesc='Tiling Wayland compositor and replacement for the i3 window manager (fork with persistent workspaces)'
+url='https://code.pepega.club/33KK/sway/src/branch/persistent-workspaces'
+license=('MIT')
depends=(
"cairo"
"gdk-pixbuf2"
+ "glib2"
+ "glibc"
"json-c"
+ "libevdev"
+ "libinput"
+ "libxcb"
+ "libxkbcommon"
"pango"
- "polkit"
"pcre2"
- "swaybg-git"
- "ttf-font"
+ "pixman"
+ "systemd-libs"
+ "wayland"
"wlroots-git"
- "xorg-server-xwayland"
+ "xcb-util-wm"
+)
+makedepends=(
+ "git"
+ "libcap"
+ "meson"
+ "scdoc"
+ "wayland-protocols"
)
optdepends=(
- "alacritty: Terminal emulator used by the default config"
- "dmenu: Application launcher"
- "grim: Screenshot utility"
- "i3status: Status line"
- "mako: Lightweight notification daemon"
- "slurp: Select a region"
- "swayidle: Idle management daemon"
- "swaylock: Screen locker"
- "wallutils: Timed wallpapers"
- "waybar: Highly customizable bar"
+ 'wmenu: Application launcher used in default configuration'
+ 'foot: Terminal emulator used in default configuration'
+ 'polkit: System privilege control. Required if not using seatd service'
+ 'swaybg: Wallpaper tool for sway'
+ 'swayidle: Idle management daemon'
+ 'swaylock: Screen locker'
+ 'xorg-xwayland: X11 support'
)
-backup=(etc/sway/config)
-arch=("i686" "x86_64")
-url="https://swaywm.org"
-source=("${_pkgname%-*}::git+https://code.pepega.club/33KK/sway.git"
- 50-systemd-user.conf)
-sha512sums=('SKIP'
- 'c2b7d808f4231f318e03789015624fd4cf32b81434b15406570b4e144c0defc54e216d881447e6fd9fc18d7da608cccb61c32e0e1fab2f1fe2750acf812d3137')
-provides=("sway")
-conflicts=("sway")
-options=(debug)
install=sway.install
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+backup=("etc/sway/config")
+source=("${_pkgname}::git+https://code.pepega.club/33KK/sway.git"
+ "50-systemd-user.conf")
+b2sums=('SKIP'
+ 'SKIP')
pkgver() {
- cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ # Calculate the version dynamically using git information
+ printf "r%s.%s" "$(git -C "$srcdir/${_pkgname}" rev-list --count HEAD)" "$(git -C "$srcdir/${_pkgname}" rev-parse --short HEAD)"
}
build() {
- arch-meson \
- -Dsd-bus-provider=libsystemd \
- -Dwerror=false \
- "$_pkgname" build
+ arch-meson "${_pkgname}" build -D sd-bus-provider=libsystemd -D werror=false
+
meson compile -C build
}
package() {
- install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
+ meson install -C build --destdir "$pkgdir"
- DESTDIR="$pkgdir" meson install -C build
-
- cd "$_pkgname"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-}
-
-post_upgrade() {
- echo "Make sure to upgrade wlroots-git and sway-git together."
- echo "Upgrading one but not the other is unsupported."
+ install -Dm644 50-systemd-user.conf -t "$pkgdir/etc/sway/config.d/"
+ install -Dm644 "${_pkgname}/LICENSE" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
}