summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAshley Towns2015-12-04 15:44:09 +1100
committerAshley Towns2015-12-04 15:44:09 +1100
commitb579830981f10b3f56793a7a38bb4d0df2dab449 (patch)
tree0147346768402ae02cc1e3d8b66b780a83c8c2b7 /PKGBUILD
parent514259fd349fc86677e4ce14d9df5d7856fee1ee (diff)
downloadaur-b579830981f10b3f56793a7a38bb4d0df2dab449.tar.gz
fix paths for glibc module
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b7a8543988e..7e0ef0862509 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,6 +30,9 @@ package() {
find "${pkgdir}/usr/bin" -type f -exec sed -i 's/libedit\.so\.2/libedit\.so\.0/g' {} \;
find "${pkgdir}/usr/lib" -type f -exec sed -i 's/libedit\.so\.2/libedit\.so\.0/g' {} \;
+ # Update glibc map paths
+ sed -i 's/\/x86_64-linux-gnu//g' "${pkgdir}/usr/lib/swift/glibc/module.map"
+
# Move license
install -dm755 ${pkgdir}/usr/share/licenses/${pkgname}
mv ${pkgdir}/usr/share/swift/LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}