summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2022-02-07 21:54:38 +0100
committerMichel Zou2022-02-07 21:54:38 +0100
commit1a5e02d840a10ed303a351955aeac75a5c27e74a (patch)
tree7e55ce423b2780b7678bf5910d50485a4566375b /PKGBUILD
parent83a4ec4328334ae3fd309b16cb4204bd3df9bc3e (diff)
downloadaur-swig-git.tar.gz
pcre2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25ab918df831..93133d9415d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,11 @@
-# Contributor: Philipp Gesang <phg42.2a@gmail.com>
-#
-# header of the original swig PKGBUILD in extra:
-# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
-# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
-
pkgname=swig-git
pkgrel=1
pkgver=rel.3.0.8.r3.ga8cf1ed
pkgdesc="Generate scripting interfaces to C/C++ code"
-arch=("i686" "x86_64")
+arch=("x86_64")
url="http://www.swig.org/"
license=("custom")
-depends=("zlib" "pcre")
+depends=("zlib" "pcre2")
makedepends=("git")
conflicts=("swig")
provides=("swig")
@@ -31,7 +25,7 @@ pkgver() {
build() {
cd "${srcdir}/${_gitname}"
./autogen.sh
- ./configure --prefix=/usr
+ ./configure --disable-all-lang --prefix=/usr
make
}
@@ -42,4 +36,3 @@ package() {
install -D -m644 LICENSE-UNIVERSITIES "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE-UNIVERSITIES
}
-# vim:ft=sh:ts=8:et:sw=2