summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLingMan2023-12-23 23:05:02 +0100
committerLingMan2023-12-24 05:42:24 +0100
commitf3de37fba610551f37446b836597f760828cc228 (patch)
tree60b89ad071a11880182cc7de2791b86e12d1cad8 /PKGBUILD
parent03746a3b5d55c975b29b9b020ce3a435081bc458 (diff)
downloadaur-swig3.tar.gz
Disable tests
No point in fixing them. See the comment for details.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b18f80fcae16..6460c83e0bdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,26 +6,31 @@
pkgname=swig3
_pkgname=swig
pkgver=3.0.12
-pkgrel=2
+pkgrel=3
pkgdesc="Generate scripting interfaces to C/C++ code (Legacy version 3)"
arch=('x86_64')
url="http://www.swig.org/"
license=('custom')
depends=('pcre' 'gcc-libs')
-checkdepends=('ruby' 'python2' 'java-environment' 'tcl' 'php' 'lua' 'ocaml' 'r' 'go' 'python2-cffi' 'camlp4')
+#checkdepends=('ruby' 'python2' 'java-environment' 'tcl' 'php' 'lua' 'ocaml' 'r' 'python2-cffi' 'camlp4')
source=(https://downloads.sourceforge.net/${_pkgname}/${_pkgname}-${pkgver}.tar.gz)
sha512sums=('5eaa2e06d8e4197fd02194051db1e518325dbb074a4c55a91099ad9c55193874f577764afc9029409a41bd520a95154095f26e33ef5add5c102bb2c1d98d33eb')
build() {
cd ${_pkgname}-${pkgver}
- ./configure --prefix=/usr --program-suffix="3.0"
+ PYTHON=python2 ./configure --prefix=/usr --program-suffix="3.0"
make
}
-check() {
- cd ${_pkgname}-${pkgver}
- make check || warning "Tests failed"
-}
+# Tests are disabled since many no longer compile properly. (Swig itself builds fine.) Some just
+# rely on old defaults that have since changed (e.g. python tests don't work since C++17), but
+# others look more complicated.
+# Haven't ever looked at most of these languages and it's unlikely some actually wants them, so I'm
+# not going to bother. The only known user needs the Python 2 parts, and those work.
+#check() {
+# cd ${_pkgname}-${pkgver}
+# PERL5LIB=. make check || warning "Tests failed"
+#}
package() {
cd ${_pkgname}-${pkgver}