summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Anderson2023-12-16 19:13:36 -0800
committerEric Anderson2023-12-16 19:13:36 -0800
commit69b0fbd2da1aa8c822b7685c344378c24bc34d28 (patch)
tree4bf50d5eb9ad998308ff392fb7c364bb0432d402 /PKGBUILD
parent44d8b7daf8fa851df79061b97fa77d24572e287b (diff)
downloadaur-swordandsworcery.tar.gz
Bump to 1.3.b807b
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 22 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7530ab730ad8..8a80b6401ab0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,37 @@
# Maintainer: Eric Anderson <ejona86@gmail.com>
pkgname=swordandsworcery
-pkgver=1.02
-pkgrel=2
+pkgver=1.3.b807b
+pkgrel=1
pkgdesc='An exploratory action adventure videogame with an emphasis on audiovisual style (game sold separately)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://www.swordandsworcery.com/'
license=('custom')
-if [ "$CARCH" == "x86_64" ]; then
- depends=('lib32-glu' 'lib32-mesa' 'lib32-curl' 'lib32-sdl')
-else
- depends=('glu' 'mesa' 'curl' 'sdl')
-fi
+depends=('glu' 'sdl2')
options=('!strip')
-_gamepkg="${pkgname}_${pkgver}.tar.gz"
+_gamepkg="sworcery_linux_64_b807bcb084022f3c98bc61c941bc5aeadc55fe05_31.7z"
source=("${pkgname}.desktop"
'http://www.swordandsworcery.com/storage/icon_512.png'
"hib://${_gamepkg}")
noextract=("${_gamepkg}")
-md5sums=('e0aca231d3b4bf8c68bf799f1e9b1201'
- '071d74203e593188ee28c0913d57d4ff'
- '2ede02c0552baeb12979bf9a68fdf399')
+sha256sums=('d1455774219b20d96cba1e99ab8c91b9ab1bbfad1b60c525be204e7b1cfa04fb'
+ '58ada6467a0606b6801eb0d1d3102cf4b32c68e32927ffa468df8f7c85fe8830'
+ '4aef955b7b4cec0a367b5f58081bac2ad9f0bc8ee2bf30c96ea4e0ea347dc2c0')
# You can download the Humble Indie Bundle file manually, or you can configure
-# DLAGENTS in makepkg.conf to auto-download.
+# DLAGENTS in makepkg.conf or ~/.makepkg.conf to auto-download.
#
-# For example, to use hib-dlagent to download files set something like this in
-# your makepkg.conf (change/add -k and add -u/-p to your needs):
-# DLAGENTS=('hib::/usr/bin/hib-dlagent -k 1a2b3c -o %o $(echo %u | cut -c 7-)')
+# For example, to auto-search through a directory containing Huble Bundle
+# downloads, set something like this in your makepkg.conf:
+# DLAGENTS=('hib::/usr/bin/bash -c /usr/bin/find\ /path/to/downloads\ -name\ $(echo\ %u\ |\ cut\ -c\ 7-)\ -exec\ ln\ -s\ \\{\\}\ %o\ \\\;\ -quit')
#
-# To auto-search through a directory containing Humble Bundle downloads, you
-# could set:
-# DLAGENTS=('hib::/usr/bin/find /path/to/downloads -name $(echo %u | cut -c 7-) -exec ln -s \{\} %o \; -quit')
-DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Download the file manually to \"$(pwd)\" or setup hib:// DLAGENT in /etc/makepkg.conf"; echo "Read this PKGBUILD for more info."; exit 1')
+# The escaping is a bit obnoxious for this use, so you probably want to make a
+# shell script for the command:
+# DLAGENTS=('hib::/home/youruser/hib-search.sh %u %o')
+#
+# /home/youruser/hib-search.sh:
+# #!/bin/bash
+# find /path/to/downloads -name ${1#hib://} -exec ln -s \{\} $2 \; -quit
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Download manually to \"$(pwd)\" or setup hib:// DLAGENT in /etc/makepkg.conf."; echo "Read this PKGBUILD for more info."; exit 1')
PKGEXT='.pkg.tar'
build(){
@@ -47,10 +47,8 @@ package(){
cp -rl . "${pkgdir}/opt/${pkgname}"
# Use system-provided versions
- rm "${pkgdir}/opt/${pkgname}/lib/libstdc++.so.6.0.16"
- rm "${pkgdir}/opt/${pkgname}/lib/libstdc++.so.6"
- rm "${pkgdir}/opt/${pkgname}/lib/libcurl.so"
- rm "${pkgdir}/opt/${pkgname}/lib/libSDL-1.2.so.0"
+ rm "${pkgdir}/opt/${pkgname}/lib/libGLU.so.1"
+ rm "${pkgdir}/opt/${pkgname}/lib/libSDL2-2.0.so.0"
install -D -m644 "${srcdir}/icon_512.png" \
"${pkgdir}/opt/${pkgname}/icon_512.png"